Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE


[RESOLVED] ERROR: libvpx decoder version must be >=0.9.1

Troubleshooting compilation problems on all platforms.

[RESOLVED] ERROR: libvpx decoder version must be >=0.9.1

Postby gribbly » Sun Oct 09, 2011 6:49 pm

Hi,

I'm getting an error when I do ./configure --enable-vpx:

Code: Select all
"ERROR: libvpx decoder version must be >=0.9.1"


./configure with no options works fine, so it seems to be a vpx issue... I guess I need a newer version of vibvpx. But I don't know where to get it from, or where to put it if I find it.

config.log is here:

http://gribbly.org/files/ffmpeg/config.log

Thanks in advance for any assistance!

RESOLVED: See reply
Last edited by gribbly on Sun Oct 09, 2011 8:06 pm, edited 1 time in total.
gribbly
 
Posts: 2
Joined: Sun Oct 09, 2011 6:43 pm

Re: ERROR: libvpx decoder version must be >=0.9.1

Postby gribbly » Sun Oct 09, 2011 8:06 pm

OK I found some help on #ffmpeg (thanks blaamann!)

http://jasonrm.net/blog/2010/may/ffmpeg/

Some of the lib source links are outdated, but the basic approach works, and I was able to build an ffmpeg with libvpx support.

RESOLVED.
gribbly
 
Posts: 2
Joined: Sun Oct 09, 2011 6:43 pm

Re: [RESOLVED] ERROR: libvpx decoder version must be >=0.9.1

Postby burek » Fri Sep 21, 2012 8:22 pm

your link gives 404.. that's why it is always good to describe it a little bit also :)
the usual issue, in cases similar to yours, is that you have one version of the library installed by your package manager (apt-get, yum, etc), which is usually outdated, like most of packages in the distro..
so the best option is to compile that library from source (and first uninstall the package from your system, to avoid conflicts) and after the successful installation, maybe also "ldconfig" command will be needed, and that's usually it :)
burek
 
Posts: 867
Joined: Mon May 09, 2011 10:16 pm
Location: Serbia


Return to Compiling FFmpeg

Who is online

Users browsing this forum: No registered users and 0 guests

cron