Page 1 of 1

Can't configure with --enable-nvenc due to "missing" CUDA

PostPosted: Thu Apr 20, 2017 10:37 am
by Bortak

let me begin with my setup/environment:

- OS: MacOS 10.12.4 (Sierra)
- CUDA Toolkit 8.0 installed
- NVidia GTX 970 (and an internal GT650M but that shouldn't be relevant)

CUDA is installed in a non-standard location but I've compensated (this way, other CUDA applications worked):
- export PATH="$PATH:<path-to-cuda>/bin"
- export DYLD_LIBRARY_PATH="$DYLD_LIBRARY_PATH:<path-to-cuda>/lib"

And now what's wrong... I'm trying to configure latest ffmpeg (3.3) with --enable-nvenc, as follows:
Code: Select all
./configure --prefix=./build --enable-swscale --enable-avfilter --enable-avresample --enable-libmp3lame --enable-libvorbis --enable-libopus --enable-libtheora --enable-libschroedinger --enable-libopenjpeg --enable-libmodplug --enable-libvpx --enable-libsoxr --enable-libspeex --enable-libass --enable-libbluray --enable-gnutls --enable-fontconfig --enable-libfreetype --enable-libfribidi --disable-libxcb --disable-libxcb-shm --disable-libxcb-xfixes --disable-indev=jack --disable-outdev=xv --disable-vda --disable-audiotoolbox --disable-videotoolbox --disable-sdl2 --enable-shared --enable-pthreads --enable-nvenc

I've tried adding --extra-cflags="-I<path-to-cuda>/include" which seems to have resolved a cuda.h not found problem but still, the issue persists. Whatever I do, I end up with:
Code: Select all
ERROR: nvenc requested, but not all dependencies are satisfied: cuda

As for config.log, the forum will not let me post a link to it, attach it (every extension is refused, even if there's none) or embed it (too many characters), so if I should provide it, I guess it has to be on demand (through PM). I had a look into it and I didn't find anything useful. I tried searching online regarding ffmpeg's requirements for CUDA but nothing came out of it and that's why I'm here to kindly ask for help :). Would anyone happen to be able to tell me how ffmpeg detects CUDA? I found nothing of interest in the configure script.

P.S.: from online resources, it seemed like CUDA 8.0 should be supported but am I wrong in gaining that impression?