Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE

This forum has not been maintained for a long time and will probably get deleted in the near future.
For faster responses to your questions, please use StackOverflow instead and tag your questions with "FFmpeg".
If you need a backup of the posts from this forum, please contact me directly.

libass error while compiling

Troubleshooting compilation problems on all platforms.

libass error while compiling

Postby Hyperion » Sun Mar 19, 2017 11:17 am


Trying to compile ffmpeg using the official compilation guide but in the end of the process, I receive the following error:

Code: Select all
root@root:~/ffmpeg_sources/ffmpeg# ./configure --prefix="$HOME/ffmpeg_build" --pkg-config-flags="--static" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin" --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-nonfree --enable-cuda --enable-nvenc
ERROR: libass not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
 mailing list or IRC #ffmpeg on .
Include the log file "config.log" produced by configure as this will help
solve the problem.

The console.log shows this at the end:

Code: Select all
gcc -L/root/ffmpeg_build/lib -Wl,--as-needed -Wl,-z,noexecstack -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/fribidi -I/usr/include/freetype2 -pthread -pthread -o /tmp/ffconf.wafluySh /tmp/ffconf.kc0VpBDX.o -lass -lm -lharfbuzz -lglib-2.0 -lpcre -lgraphite2 -lfontconfig -lexpat -lfreetype -lexpat -lfribidi -lfreetype -lz -lpng16 -lm -lz -lm -lm -lbz2 -lz -pthread
/usr/bin/ld: cannot find -lpng16
collect2: error: ld returned 1 exit status
ERROR: libass not found using pkg-config

The following command returns no errors:

Code: Select all
root@root:~/ffmpeg_sources/ffmpeg# pkg-config --exists --print-errors libass

Any suggestions?

Thanks in advance

EDIT: I fixed it. My machine was missing some *-dev libs.
Posts: 2
Joined: Wed Mar 15, 2017 9:15 am

Re: libass error while compiling

Postby llogan » Mon Mar 20, 2017 5:35 pm

EDIT: I fixed it. My machine was missing some *-dev libs.

Which ones?
Get an answer more quickly by providing your actual ffmpeg command and the complete console output. Use the code button to format your command and output or your question will be ignored.
Posts: 2363
Joined: Fri Jan 25, 2013 9:47 pm
Location: Alaska

Return to Compiling FFmpeg

Who is online

Users browsing this forum: No registered users and 2 guests