Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE


This forum has not been maintained for a long time and will probably get deleted in the near future.
For faster responses to your questions, please use StackOverflow instead and tag your questions with "FFmpeg".
If you need a backup of the posts from this forum, please contact me directly.

Enable DeckLink ?

Troubleshooting compilation problems on all platforms.

Enable DeckLink ?

Postby jpham » Thu Sep 08, 2016 6:46 am

s there a cheat sheet on how to install DeckLink (window) ?
I look at the html/manual and it says - "To enable this input device, you need the Blackmagic DeckLink SDK and you need to configure with the appropriate --extra-cflags and --extra-ldflags. On Windows, you need to run the IDL files through widl"

so where can I download widl ?
what are the --extra-cflags that I should use ?
what are the --extra-ldflags ?

and where do I put the DeckLink*.* ?

when I run ./configure --enable-decklink - the configure search and says
couldn't find DeckLinkAPI.h - I can see it - is there some special dir that I need to put DeckLink*.* in ? :roll:
jpham
 
Posts: 9
Joined: Thu Sep 08, 2016 3:03 am

Re: Enable DeckLink ?

Postby ptmkenny » Thu Jan 26, 2017 7:26 pm

I'm having trouble getting Decklink enabled on Windows 10 as well.

"On Windows, you need to run the IDL files through widl"-- could someone explain more concretely what needs to be done?

Also, the DeckLink SDK is required-- is this the same as the Desktop Video SDK?
ptmkenny
 
Posts: 1
Joined: Thu Jan 26, 2017 7:23 pm


Return to Compiling FFmpeg

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest