Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE


HEVC performance

Discussions about problems encountered using ffplay.
Forum rules
FFmpeg is in a state of perpetual development and we do not currently have the person power to backport fixes to official releases. As such, if you wish to query or report a bug, you must try with the latest development branch revision of FFmpeg to confirm the issue still exists. The latest FFmpeg can be downloaded from here: http://www.ffmpeg.org/download.html

HEVC performance

Postby csdesigns » Thu Sep 29, 2016 9:27 pm

I am curious if there is any way to improve decode performance of HEVC/H.265 in ffplay on mac?

I am running ffplay version 3.1.3 but all of my HEVC/H.265 media plays back at below 100% speed. In general, I see dropped frames and stuttered performance for all videos of at least 1080p60 and higher. I have tried compiling ffplay using brew and yasm, but have also experienced the same issues with other publicly available binaries I have downloaded. So far, I have found mpv to offer the best decode performance (the only player that can decode UHDp60 smoothly) for HEVC Main10 content. But I have also just discovered that ffplay is the only player that can display true 10bit video on my displays. All other 'players' I have tested (including mpv, and not referring to editors such as FCPX) display 10bit source material as 8bit.

It is crucial for my testing to have a high-performance HEVC decoder that can display 10bit source videos accurately. If there are any mods or switches that I should be aware of, I'd very much appreciate that insight! I am running Mac OS X 10.11.6 on a 4GHz iMac 5K Late 2015 with 32GB RAM and AMD M395X connected to the internal display and a LG 27MU67-B. Thanks in advance for any assistance that can be provided.
csdesigns
 
Posts: 1
Joined: Thu Sep 29, 2016 8:46 pm

Return to ffplay

Who is online

Users browsing this forum: No registered users and 1 guest