Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE


This forum has not been maintained for a long time and will probably get deleted in the near future.
For faster responses to your questions, please use StackOverflow instead and tag your questions with "FFmpeg".
If you need a backup of the posts from this forum, please contact me directly.

SDL: could not set video mode - exiting

Discussions about problems encountered using ffplay.
Forum rules
FFmpeg is in a state of perpetual development and we do not currently have the person power to backport fixes to official releases. As such, if you wish to query or report a bug, you must try with the latest development branch revision of FFmpeg to confirm the issue still exists. The latest FFmpeg can be downloaded from here: http://www.ffmpeg.org/download.html

SDL: could not set video mode - exiting

Postby winter » Tue Nov 08, 2016 3:38 pm

When I use ffplay to play any flv or mp4, then I get the error.

Code: Select all
SDL: could not set video mode - exiting


What could it be?
Help me please!
CentOS 7
winter
 
Posts: 1
Joined: Tue Nov 08, 2016 3:35 pm

Re: SDL: could not set video mode - exiting

Postby llogan » Tue Nov 08, 2016 6:20 pm

Please show the complete console output.
Get an answer more quickly by providing your actual ffmpeg command and the complete console output. Use the code button to format your command and output or your question will be ignored.
llogan
 
Posts: 2354
Joined: Fri Jan 25, 2013 9:47 pm
Location: Alaska

Re: SDL: could not set video mode - exiting

Postby noscar » Wed Aug 02, 2017 3:22 pm

I have encountered the same error when trying to play an mp3 file with ffplay.
Here is the full output of the command used:

$root ffplay audio.mp3
Input #0, mp3, from 'audio.mp3' : 0KB vq= 0KB sq= 0B f=0/0
Metadata:
major_brand: isom
minor_version: 512
compatible_brands: isomiso2avc1mp41
encoder : Lavf46.40.101
Duration: 00:08:24.98, start: 0.023021, birate: 128kb/s
Stream #0:0: Audio: mp3, 40000 Hz, stereo, s16p, 128 kb/s
Metadata:
encoder : Lavc56.60
SDL: could not set video mode - exiting
$root
noscar
 
Posts: 1
Joined: Wed Aug 02, 2017 3:11 pm


Return to ffplay

Who is online

Users browsing this forum: No registered users and 1 guest