Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE


vp9 and CODEC_CAP_DELAY

Who doesn't love them :) But for faster response on your Bug Reports, please visit: http://www.ffmpeg.org/bugreports.html
Forum rules
First of all, please remember that all the developers working on FFmpeg are volunteers, we are not paid for analyzing, debugging, fixing and answering bug reports. While we try our best to create high quality software and be responsive, if you should not get an answer, please consider the above and be aware of the fact that we receive many bug reports and the amount of time it takes to deal with them can be substantial. Nevertheless most issues get resolved, just please understand that there are no guarantees nor promises.

vp9 and CODEC_CAP_DELAY

Postby tuup » Thu Aug 25, 2016 6:23 pm

I am using ffmpeg to play vp9 videos and I encounter a situation where a certain video stops few frames before the end.
Doc for avcodec_decode_video2 function says that for codecs which have the CODEC_CAP_DELAY capability we need to feed avcodec_decode_video2 with null packets in order to receive all frames.
vp9 codec does not have this capability set, but nonetheless I try to send null packet and codec gets me all frames.
So the questions are:
1. Am I doing it right?
2. Should vp9 have CODEC_CAP_DELAY capability set?
tuup
 
Posts: 1
Joined: Thu Aug 25, 2016 6:02 pm

Re: vp9 and CODEC_CAP_DELAY

Postby llogan » Fri Aug 26, 2016 6:46 pm

You should ask libav-user: the mailing list for questions involving FFmpeg library usage.
Get an answer more quickly by providing your actual ffmpeg command and the complete console output. Use the code button to format your command and output or your question will be ignored.
llogan
 
Posts: 2332
Joined: Fri Jan 25, 2013 9:47 pm
Location: Alaska


Return to Bugs, bugs, bugs :)

Who is online

Users browsing this forum: No registered users and 1 guest