Home/News | About | Download | Documentation | Forum | Bug Reports | Contact | Donations | Consulting | Projects | Legal | Security | FATE


This forum has not been maintained for a long time and will probably get deleted in the near future.
For faster responses to your questions, please use StackOverflow instead and tag your questions with "FFmpeg".
If you need a backup of the posts from this forum, please contact me directly.

Wrong FPS shown in WMV

Discussions about problems encountered using ffmpeg.
Forum rules
FFmpeg is in a state of perpetual development and we do not currently have the person power to backport fixes to official releases. As such, if you wish to query or report a bug, you must try with the latest development branch revision of FFmpeg to confirm the issue still exists. The latest FFmpeg can be downloaded from here: http://www.ffmpeg.org/download.html

Wrong FPS shown in WMV

Postby mr.tau » Tue May 30, 2017 12:49 pm

Hello guys,
Could you please help me out with the following issue?

I am trying to create a video using wmv2 codec (Windows Media Video 8) and everything looks pretty fine and working, until I rclick on the video in Windows Explorer -> Properties -> Details tab.
The issue is that it shows 30FPS instead of 25FPS.
MediaInfo (Win) shows 25FPS as well, MediaInfo (Mac) shows "NaN" (Not a Number I guess?)

The thing is, I need the right value readable right from the Windows Explorer.
Do you have any idea what I am doing wrong or could you please suggest any soliton or workaround?

The way I am creating the video:
Frames 001-250.png converting to WMV.
Code: Select all
ffmpeg.exe -f image2 -framerate 25 -i %03d.png -vcodec wmv2 -r:v 25 -b:v 10201k -minrate 10201k -maxrate 10201k -bufsize 600000k out2.wmv


Output of the command:
Image

MediaInfo output:
Image

But the Explorer output!! :-(
Image

I think the video itself would be fine, expcept the infromation in its header? Is there a easy way how to just edit the headers?

I would be greatful for any hint.

Thank you very much.
Petr
mr.tau
 
Posts: 1
Joined: Tue May 30, 2017 12:34 pm

Return to ffmpeg

Who is online

Users browsing this forum: Baidu [Spider], Bing [Bot], Google [Bot] and 7 guests